bundlerのバージョン固定してbundle update

rubocopのgemだけバージョンアップしたく、以下のようにコマンドを実行しておりました。

conservativeというオプションは、依存関係にあるgemをupdateしないためのオプションです。

bundle  update  --conservative rubocop

 

しかし、これだとbundlerまで2.0.2へアップデートされてしまい、CIが落ちる問題が発生しておりました。

 

そこでbundlerのバージョンを指定してアップデートできることを知り、以下のように実行したところ、無事rubocopとその依存関係にあるgemのみアップデートできました!

 

bundle _1.16.2_ update  --conservative rubocop

 

 

感想その他

以下のリンクをみてみたら、使ったことないオプションがたくさんありました。。。!!

bundler.io